Inicio > Apache en Ubuntu > Problema con phpMyAdmin, mbstring extension y Ubuntu 16.04

Problema con phpMyAdmin, mbstring extension y Ubuntu 16.04

Supongo que esto dentro de poco tiempo no servirá para nada porque habrán arreglado la instalación de PHP7. Pero en mayo de 2016 ha estado curioso dejar el servidor fino.

Vale, he actualizado Ubuntu a 16.04, además de pasarme a php7 sobre Apache. La cantidad de problemas que estoy encontrando está siendo interesante.

El último ha sido con la configuración de phpmyadmin (en este caso es sobre MariaDB, pero vamos, que sobre MySQL creo que pasa lo mismo).

Instalo mi paquete de phpmyadmin y no funciona, a pesar de reiniciar el servicio. Lo que sucede es que no se ha cargado la configuración de phpmyadmin en apache. Para ello:

sudo nano /etc/apache2/apache2.conf

y dentro incluimos:

Include /etc/phpmyadmin/apache.conf

Tras instalarlo y acceder a http://localhost/phpmyadmin te encuentras el siguiente error:

The mbstring extension is missing. Please check your PHP configuration.

La solución es:

sudo apt-get install php-mbstring php7.0-mbstring php-gettext
sudo service apache2 restart

Me estoy encontrando en muchos casos que el php7 no va NADA FINO y tienes que reinstalar paquetes o instalar algunos que normalmente tienes instalados, véase el php-curl.
Además, el apt-get install php7 me ha estado fallando por culpa del paquete php-fpm. Lo he solucionado descargando los fuentes de PHP e instalando a la vieja usanza, con sus configures, sus makes y sus cosas.

Es lo que pasa por pasarte a una versión “estable” antes de la cuenta.

  1. linchu00
    7 de mayo de 2016 a las 16:06

    Me ha funcionado, gracias.

  2. 30 de mayo de 2016 a las 10:43

    Hola Pedro

    Muchas gracias por las recetas. Me han funcionado a la perfección. Aquí uso Ubuntu-Gnome 16.04, con apache2 y php7.

    En mi caso, si cargaba el phpmyadmin, pero me daba el error de mbstring. Con instalar los paquetes que recomendabas, todo ha vuelto a funcionar.

    Repito, muchas gracias, porque me estaba volviendo loco buscando y rebuscando para solucionar el problema.

    Saudos

  3. mcardenas
    7 de junio de 2016 a las 12:18

    Gracias por la info!! Funciona!!

  4. 23 de octubre de 2016 a las 22:42

    Impresionante hace 3 días que estoy con esto y me fijé en 30 foros y nadaaaa. Ahora me funcionó. Enormes gracias!!!

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: